<!DOCTYPE html>
<html lang="en">
<head>

    <title>A new wave of Linux applications</title>
    <meta charset="utf-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge" />
    <meta name="HandheldFriendly" content="True" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />

    <style>
        :root {
            --button-bg-color: #ffffff;
            --button-text-color: var(--color-darkgrey);
        }
    </style>

    <link rel="stylesheet" type="text/css" href="/assets/built/screen.css?v=3c2405e8bf" />

    <link rel="icon" href="/favicon.png" type="image/png" />
    <link rel="canonical" href="https://tuxphones.com/convergent-linux-phone-apps/" />
    <meta name="referrer" content="no-referrer-when-downgrade" />
    
    <meta property="og:site_name" content="TuxPhones - Linux phones, tablets and portable devices" />
    <meta property="og:type" content="article" />
    <meta property="og:title" content="A new wave of Linux applications" />
    <meta property="og:description" content="With the start of the new year, we can see a new trend delineating Linux software. Phosh with its newbord libadwaita, KDE&#x27;s Kirigami and Maui Shell show that – like it or not – the era of convergent Linux applications has just started.  After all, even laptop screens are not too big" />
    <meta property="og:url" content="https://tuxphones.com/convergent-linux-phone-apps/" />
    <meta property="og:image" content="https://tuxphones.com/content/images/2022/01/convergent-apps-header-1.png" />
    <meta property="article:published_time" content="2022-02-11T10:45:00.000Z" />
    <meta property="article:modified_time" content="2022-02-11T10:45:00.000Z" />
    <meta property="article:tag" content="Convergence" />
    
    <meta name="twitter:card" content="summary_large_image" />
    <meta name="twitter:title" content="A new wave of Linux applications" />
    <meta name="twitter:description" content="With the start of the new year, we can see a new trend delineating Linux software. Phosh with its newbord libadwaita, KDE&#x27;s Kirigami and Maui Shell show that – like it or not – the era of convergent Linux applications has just started.  After all, even laptop screens are not too big" />
    <meta name="twitter:url" content="https://tuxphones.com/convergent-linux-phone-apps/" />
    <meta name="twitter:image" content="https://tuxphones.com/content/images/2022/01/convergent-apps-header-1.png" />
    <meta name="twitter:label1" content="Written by" />
    <meta name="twitter:data1" content="Raffaele T." />
    <meta name="twitter:label2" content="Filed under" />
    <meta name="twitter:data2" content="Convergence" />
    <meta name="twitter:site" content="@tuxphones" />
    <meta property="og:image:width" content="1920" />
    <meta property="og:image:height" content="1080" />
    
    <script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "Article",
    "publisher": {
        "@type": "Organization",
        "name": "TuxPhones - Linux phones, tablets and portable devices",
        "url": "https://tuxphones.com/",
        "logo": {
            "@type": "ImageObject",
            "url": "https://tuxphones.com/content/images/2019/06/tuxphones1-horizontal-banner.png"
        }
    },
    "author": {
        "@type": "Person",
        "name": "Raffaele T.",
        "image": {
            "@type": "ImageObject",
            "url": "https://tuxphones.com/content/images/2019/08/pp.jpeg",
            "width": 640,
            "height": 640
        },
        "url": "https://tuxphones.com/author/r/",
        "sameAs": []
    },
    "headline": "A new wave of Linux applications",
    "url": "https://tuxphones.com/convergent-linux-phone-apps/",
    "datePublished": "2022-02-11T10:45:00.000Z",
    "dateModified": "2022-02-11T10:45:00.000Z",
    "image": {
        "@type": "ImageObject",
        "url": "https://tuxphones.com/content/images/2022/01/convergent-apps-header-1.png",
        "width": 1920,
        "height": 1080
    },
    "keywords": "Convergence",
    "description": "With the start of the new year, we can see a new trend delineating Linux\nsoftware. Phosh with its newbord libadwaita, KDE&#x27;s Kirigami and Maui Shell show\nthat – like it or not – the era of convergent Linux applications has just\nstarted. \n\nAfter all, even laptop screens are not too big once one starts tiling windows,\nand a single codebase between mobile and desktop apps would not only enable\nhigher maintainability and a wider user base, but having windows adapting\nflawlessly to tiny squares on the",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://tuxphones.com/"
    }
}
    </script>

    <meta name="generator" content="Ghost 4.32" />
    <link rel="alternate" type="application/rss+xml" title="TuxPhones - Linux phones, tablets and portable devices" href="https://tuxphones.com/rss/" />
    <script defer src="https://unpkg.com/@tryghost/portal@~1.12.0/umd/portal.min.js" data-ghost="https://tuxphones.com/" crossorigin="anonymous"></script><style id="gh-members-styles">.gh-post-upgrade-cta-content,
.gh-post-upgrade-cta {
    display: flex;
    flex-direction: column;
    align-items: center;
    font-family: -apple-system, BlinkMacSystemFont, 'Segoe UI', Roboto, Oxygen, Ubuntu, Cantarell, 'Open Sans', 'Helvetica Neue', sans-serif;
    text-align: center;
    width: 100%;
    color: #ffffff;
    font-size: 16px;
}

.gh-post-upgrade-cta-content {
    border-radius: 8px;
    padding: 40px 4vw;
}

.gh-post-upgrade-cta h2 {
    color: #ffffff;
    font-size: 28px;
    letter-spacing: -0.2px;
    margin: 0;
    padding: 0;
}

.gh-post-upgrade-cta p {
    margin: 20px 0 0;
    padding: 0;
}

.gh-post-upgrade-cta small {
    font-size: 16px;
    letter-spacing: -0.2px;
}

.gh-post-upgrade-cta a {
    color: #ffffff;
    cursor: pointer;
    font-weight: 500;
    box-shadow: none;
    text-decoration: underline;
}

.gh-post-upgrade-cta a:hover {
    color: #ffffff;
    opacity: 0.8;
    box-shadow: none;
    text-decoration: underline;
}

.gh-post-upgrade-cta a.gh-btn {
    display: block;
    background: #ffffff;
    text-decoration: none;
    margin: 28px 0 0;
    padding: 8px 18px;
    border-radius: 4px;
    font-size: 16px;
    font-weight: 600;
}

.gh-post-upgrade-cta a.gh-btn:hover {
    opacity: 0.92;
}</style>
    <script defer src="/public/cards.min.js?v=3c2405e8bf"></script>
    <link rel="stylesheet" type="text/css" href="/public/cards.min.css?v=3c2405e8bf">
    <!-- google verification code -->
<meta name="google-site-verification" content="SQNFjLlJsdboylqWuxb6O5YgPqYn8sAI_YyKr4m5PRs" />
<meta name="nano" content="nano_16x9cqkb1b375cc78ihuiy3npwac1smk6qpid18hhfrt55swsyj1dkw1z9i6"/>

<!-- casper customization -->
<style>
    .site-logo {
        max-height: 100px;
    }
    .site-description {
        font-size: 1.5em;
    }
    .comments-button {
        font-family: monospace;
    	background-color: #00ba00;
    	padding: 12px;
    	color: #fff !important;
    	font-weight: 800;
   		font-variant: all-small-caps;
    	letter-spacing: 0.03em;
    	border-radius: 8px;
    }
</style>

<script async src="https://media.ethicalads.io/media/client/ethicalads.min.js"></script>
<style>:root {--ghost-accent-color: #082330;}</style>

</head>
<body class="post-template tag-convergence">
<div class="viewport">

    <header id="gh-head" class="gh-head has-cover">
        <nav class="gh-head-inner inner gh-container">

            <div class="gh-head-brand">
                <a class="gh-head-logo" href="https://tuxphones.com">
                        <img src="https://tuxphones.com/content/images/2019/06/tuxphones1-horizontal-banner.png" alt="TuxPhones - Linux phones, tablets and portable devices" />
                </a>
                <a class="gh-burger" role="button">
                    <div class="gh-burger-box">
                        <div class="gh-burger-inner"></div>
                    </div>
                </a>
            </div>
            <div class="gh-head-menu">
                <ul class="nav">
    <li class="nav-home"><a href="https://tuxphones.com/">Home</a></li>
    <li class="nav-flashes"><a href="https://tuxphones.com/tag/flashes/">⚡ Flashes</a></li>
    <li class="nav-quick-start-guide"><a href="https://tuxphones.com/2019-everything-running-linux-smartphone-guide/">Quick start guide</a></li>
    <li class="nav-best-linux-phones"><a href="https://tuxphones.com/best-linux-phones-buying-guide-2022/">Best Linux phones</a></li>
    <li class="nav-distros"><a href="https://tuxphones.com/all-linux-distributions-for-smartphones/">Distros</a></li>
    <li class="nav-200-tuxphones"><a href="https://many.tuxphones.com/">200+ tuxphones</a></li>
    <li class="nav-contact"><a href="mailto:contact@tuxphones.com">✉️ Contact</a></li>
    <li class="nav-support"><a href="https://tuxphones.com/support/">❤️ Support</a></li>
</ul>

            </div>
            <div class="gh-head-actions">
                <div class="gh-social">
                        <a class="gh-social-twitter" href="https://twitter.com/tuxphones" title="Twitter" target="_blank" rel="noopener"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32"><path d="M30.063 7.313c-.813 1.125-1.75 2.125-2.875 2.938v.75c0 1.563-.188 3.125-.688 4.625a15.088 15.088 0 0 1-2.063 4.438c-.875 1.438-2 2.688-3.25 3.813a15.015 15.015 0 0 1-4.625 2.563c-1.813.688-3.75 1-5.75 1-3.25 0-6.188-.875-8.875-2.625.438.063.875.125 1.375.125 2.688 0 5.063-.875 7.188-2.5-1.25 0-2.375-.375-3.375-1.125s-1.688-1.688-2.063-2.875c.438.063.813.125 1.125.125.5 0 1-.063 1.5-.25-1.313-.25-2.438-.938-3.313-1.938a5.673 5.673 0 0 1-1.313-3.688v-.063c.813.438 1.688.688 2.625.688a5.228 5.228 0 0 1-1.875-2c-.5-.875-.688-1.813-.688-2.75 0-1.063.25-2.063.75-2.938 1.438 1.75 3.188 3.188 5.25 4.25s4.313 1.688 6.688 1.813a5.579 5.579 0 0 1 1.5-5.438c1.125-1.125 2.5-1.688 4.125-1.688s3.063.625 4.188 1.813a11.48 11.48 0 0 0 3.688-1.375c-.438 1.375-1.313 2.438-2.563 3.188 1.125-.125 2.188-.438 3.313-.875z"/></svg>
</a>
                </div>

                    <a class="gh-head-button" href="#/portal/signup" data-portal="signup">Subscribe</a>
            </div>
        </nav>
    </header>



    <div class="site-content">
        



<main id="site-main" class="site-main">
    <article class="article post tag-convergence ">

        <header class="article-header gh-canvas">

            <section class="article-tag">
                <a href="https://tuxphones.com/tag/convergence/">Convergence</a>
            </section>

            <h1 class="article-title">A new wave of Linux applications</h1>


<div style="min-height: 150px; text-align: center;">
    <div data-ea-publisher="tuxphonescom" data-ea-type="text" id="post-text--convergent-linux-phone-apps" data-ea-keywords="linux|privacy|arm|smartphone|repair|sustainability|librem|pinephone|programming"></div>
</div>

            <div class="article-byline">
                <section class="article-byline-content">
                    <ul class="author-list">
                        <li class="author-list-item">
                            <a href="/author/r/" class="author-avatar">
                                <img class="author-profile-image" src="/content/images/size/w100/2019/08/pp.jpeg" alt="Raffaele T." />
                            </a>
                        </li>
                    </ul>
                    <div class="article-byline-meta">
                        <h4 class="author-name"><a href="/author/r/">Raffaele T.</a></h4>
                        <div class="byline-meta-content">
                            <time class="byline-meta-date" datetime="2022-02-11">Feb 11, 2022</time>
                            <span class="byline-reading-time"><span class="bull">&bull;</span> 4 min read</span>
                        </div>
                    </div>
                </section>
            </div>

            <figure class="article-image">
                <img
                    srcset="/content/images/size/w300/2022/01/convergent-apps-header-1.png 300w,
                            /content/images/size/w600/2022/01/convergent-apps-header-1.png 600w,
                            /content/images/size/w1000/2022/01/convergent-apps-header-1.png 1000w,
                            /content/images/size/w2000/2022/01/convergent-apps-header-1.png 2000w"
                    sizes="(min-width: 1400px) 1400px, 92vw"
                    src="/content/images/size/w2000/2022/01/convergent-apps-header-1.png"
                    alt="A new wave of Linux applications"
                />
            </figure>
        </header>

        <section class="gh-content gh-canvas">
            <p>With the start of the new year, we can see a new trend delineating Linux software. Phosh with its newbord <em>libadwaita</em>, KDE's <em>Kirigami</em> and Maui Shell show that – like it or not – the era of convergent Linux applications has just started. </p><p>After all, even laptop screens are not too big once one starts <em>tiling</em> windows, and a single codebase between mobile and desktop apps would not only enable higher maintainability and a wider user base, but having windows adapting flawlessly to tiny squares on the screen sounds tempting even for those who do not plan on using the penguin OS on touchscreen-based devices just yet. </p><p>Furthermore, the variety of projects that are enabling convergence on their applications is growing at a fast rate, with KDE, GNOME, Nitrux, Elementary and Jingling among others shifting their interest on mobile-ready and touch-friendly applications for the future of Linux.</p><p>The striking results that so many new Linux application seem to naturally accomplish, and an increase reverting the reported lack of new FOSS apps of the past years, are finally going against the stereotype of ugliness of free software interfaces with state-of-the-art usability, clear and modern UX lines combined with a fully featured experience, no matter the size of the screens. This is the result of a rare, although indirect, collaboration between Linux desktops, with leading UX designers dedicating to improving the usability of Linux software to its finest details: GNOME's dedicated UX team, alongside designers like Sophie Herold, KDE's Niccolò Venerandi, Danielle Foré and others are tracing new guidelines for software that goes on par, if not often beyond, commercial software.</p><figure class="kg-card kg-image-card kg-card-hascaption"><img src="https://tuxphones.com/content/images/2022/01/linux-new-convegent-apps-ensembles-flathub.png" class="kg-image" alt loading="lazy" width="1920" height="1080" srcset="https://tuxphones.com/content/images/size/w600/2022/01/linux-new-convegent-apps-ensembles-flathub.png 600w, https://tuxphones.com/content/images/size/w1000/2022/01/linux-new-convegent-apps-ensembles-flathub.png 1000w, https://tuxphones.com/content/images/size/w1600/2022/01/linux-new-convegent-apps-ensembles-flathub.png 1600w, https://tuxphones.com/content/images/2022/01/linux-new-convegent-apps-ensembles-flathub.png 1920w" sizes="(min-width: 720px) 720px"><figcaption>The newly developed <em>Ensembles app</em> enables audio production with a stylish interface</figcaption></figure><p>An example is <em>Flathub</em>, where new applications using the most modern toolkits and UX strategy appear every day, providing "just works" alternatives to complex older FOSS software,, in a boom similar to that seen around 2012 on Apple's Mac App Store. This encourages high competition between software, and most small use cases of missing usability are covered.</p><p>The toolkits enabling this are firstly Qt-based MauiKit and GNOME's GTK4, and its mobile-friendly <em>libadwaita</em>, which provide a superbly fast workflow for Linux applications, with the only real thing we still miss yet being perhaps a <em>tiny</em>, resource-effective toolkit for low-end devices. Developing apps on Linux has just become as fast as opening GNOME's (somewhat new) <em>Builder</em> IDE, programming the logic over a base template in a variety of languages, and deploying it through Flatpak and app stores. To take up the comparison once again, this mimics a <em>lot</em> what Xcode used to be around 2009, in spite of the drastically smaller team working on it. But as usual, FOSS desktops are essentially maintained by volunteers in all their entirety, so donating to your reference environment will encourage work on new projects.</p><figure class="kg-card kg-gallery-card kg-width-wide kg-card-hascaption"><div class="kg-gallery-container"><div class="kg-gallery-row"><div class="kg-gallery-image"><img src="https://tuxphones.com/content/images/2022/02/screenshot-symbols.png" width="1183" height="665" loading="lazy" alt srcset="https://tuxphones.com/content/images/size/w600/2022/02/screenshot-symbols.png 600w, https://tuxphones.com/content/images/size/w1000/2022/02/screenshot-symbols.png 1000w, https://tuxphones.com/content/images/2022/02/screenshot-symbols.png 1183w" sizes="(min-width: 720px) 720px"></div><div class="kg-gallery-image"><img src="https://tuxphones.com/content/images/2022/02/screenshot-3d-appdata.png" width="1134" height="638" loading="lazy" alt srcset="https://tuxphones.com/content/images/size/w600/2022/02/screenshot-3d-appdata.png 600w, https://tuxphones.com/content/images/size/w1000/2022/02/screenshot-3d-appdata.png 1000w, https://tuxphones.com/content/images/2022/02/screenshot-3d-appdata.png 1134w" sizes="(min-width: 720px) 720px"></div></div></div><figcaption><em><a href="https://www.cvfosammmm.org/setzer/">Setzer</a> </em>and <em><a href="https://www.cvfosammmm.org/porto/">Porto</a></em> are modern, powerful, Linux-only editors for <em>LaTex</em> and <em>Jupyter </em>scientific writing respectively</figcaption></figure><p>As the consistent sample shows, this looks like a general direction rather than a passing trend. A strong technical basis for convergence is being built, and we may expect the majority of Linux software developed in the upcoming 5 to 10 years to follow these guidelines and core ideas. In this case, unlike in the unsuccessful past examples such as Windows Phone, where different codebases were sold under the same market name with a very limited degree of compatibility, in this case we are <em>already</em> at a point of real convergence, as anyone trying a Linux phone will notice, which we will hope that will end the legacy iPhone-inspired trend of a drastic codebase rewriting for mobile devices, which was initially rather enforced by the enormous performance gap between desktops and mobiles at the time (the first iPhones and Android devices ran on 400MHz, ARM11 CPU, whereas modern ones are comparable to laptops from few years ago) than from deeper philosophical grounds, or technical advantages.</p><p>Therefore, given the current status of understaffing of most Linux mobile and desktop projects, this shift to convergence is almost universally good. Enabling top maintainability, since all devices will use the same projects instead of a lot of forks and adaptions, will help developers focus on stability and usability without a real loss in performance. Furthermore, this might hopefully bring to having much lighter apps on desktops (e.g., GTK and GNOME being considerably optimized for performance after the mobile shift and the Librem 5 launch), and finally feature-full apps on phones, that will turn into usable desktop applications as soon as a video cable is plugged (as we have seen e.g. <a href="https://www.youtube.com/watch?v=y9pOCXy0Q94">on the PinePhone</a>). </p><p>What is particularly important is how this tightens the gap between desktop and mobile Linux devices, and will hopefully make Linux smartphones nothing less than pocket-sized ARM computers. And finally, in the long time, make the Linux desktop environment more competitive than ever.</p><figure class="kg-card kg-image-card kg-card-hascaption"><img src="https://tuxphones.com/content/images/2022/02/image.png" class="kg-image" alt loading="lazy" width="1024" height="576" srcset="https://tuxphones.com/content/images/size/w600/2022/02/image.png 600w, https://tuxphones.com/content/images/size/w1000/2022/02/image.png 1000w, https://tuxphones.com/content/images/2022/02/image.png 1024w" sizes="(min-width: 720px) 720px"><figcaption>The <em>PinePhone </em>with its <a href="https://pine64.com/product/pinephone-pinephone-pro-keyboard-case/">keyboard</a> looks indeed like a pocket-sized computer (<a href="https://www.pine64.org/2021/12/31/happy-new-year-the-keyboard-and-cases-are-here/">source</a>)</figcaption></figure>
        </section>

        
        <section class="article-comments gh-canvas">
<script defer src="https://comments.tuxphones.com/js/commento.js"></script>
<div id="commento"></div>
        </section>
        

    </article>
</main>


    <section class="footer-cta ">
        <div class="inner">
            <h2>Sign up for more like this.</h2>
            <a class="footer-cta-button" href="#/portal" data-portal>
                <div class="footer-cta-input">Enter your email</div>
                <span>Subscribe</span>
            </a>
        </div>
    </section>



<aside class="read-more-wrap">
    <div class="read-more inner">


                    
<article class="post-card post ">

    <a class="post-card-image-link" href="/cutiepi-review-open-hardware-linux-tablet-raspberry-pi-4/">
        <img class="post-card-image"
            srcset="/content/images/size/w300/2022/01/cutiepi-raspberry-pi-linux-tablet-22.jpg 300w,
                    /content/images/size/w600/2022/01/cutiepi-raspberry-pi-linux-tablet-22.jpg 600w,
                    /content/images/size/w1000/2022/01/cutiepi-raspberry-pi-linux-tablet-22.jpg 1000w,
                    /content/images/size/w2000/2022/01/cutiepi-raspberry-pi-linux-tablet-22.jpg 2000w"
            sizes="(max-width: 1000px) 400px, 800px"
            src="/content/images/size/w600/2022/01/cutiepi-raspberry-pi-linux-tablet-22.jpg"
            alt="CutiePi Tablet review: The open-hardware Linux tablet"
            loading="lazy"
        />
    </a>

    <div class="post-card-content">

        <a class="post-card-content-link" href="/cutiepi-review-open-hardware-linux-tablet-raspberry-pi-4/">
            <header class="post-card-header">
                <h2 class="post-card-title">CutiePi Tablet review: The open-hardware Linux tablet</h2>
            </header>
            <div class="post-card-excerpt">
                <p>IntroductionOver the last years, we have seen many Linux-powered tablets, all of which developed with different approaches to "openness". For instance, the PineTab trades performance and a somewhat conservative design for a very low selling price and full Linux support, which made its demand high to the point of becoming</p>
            </div>
        </a>

        <footer class="post-card-meta">
            <ul class="author-list">
                <li class="author-list-item">
                    <a href="/author/r/" class="static-avatar">
                        <img class="author-profile-image" src="/content/images/size/w100/2019/08/pp.jpeg" alt="Raffaele T." loading="lazy" />
                    </a>
                </li>
            </ul>
            <div class="post-card-byline-content">
                <span><a href="/author/r/">Raffaele T.</a></span>
                <span class="post-card-byline-date"><time datetime="2022-02-01">Feb 1, 2022</time> <span class="bull">&bull;</span> 12 min read</span>
            </div>
        </footer>

    </div>

</article>
                    
<article class="post-card post ">

    <a class="post-card-image-link" href="/postmarketos-linux-live-usb-fastboot-network-boot/">
        <img class="post-card-image"
            srcset="/content/images/size/w300/2022/01/postmarketos-netboot-linux-live-usb.png 300w,
                    /content/images/size/w600/2022/01/postmarketos-netboot-linux-live-usb.png 600w,
                    /content/images/size/w1000/2022/01/postmarketos-netboot-linux-live-usb.png 1000w,
                    /content/images/size/w2000/2022/01/postmarketos-netboot-linux-live-usb.png 2000w"
            sizes="(max-width: 1000px) 400px, 800px"
            src="/content/images/size/w600/2022/01/postmarketos-netboot-linux-live-usb.png"
            alt="You can now live-boot postmarketOS on Android phones"
            loading="lazy"
        />
    </a>

    <div class="post-card-content">

        <a class="post-card-content-link" href="/postmarketos-linux-live-usb-fastboot-network-boot/">
            <header class="post-card-header">
                <h2 class="post-card-title">You can now live-boot postmarketOS on Android phones</h2>
            </header>
            <div class="post-card-excerpt">
                <p>To spread awareness of the Linux ecosystem, the very first "Live CDs" played a crucial role: by taking away most of the fear of overwriting their hard drives, they allowed more people to test and effectively use any spin of the Operating System, and by keeping the filesystem in RAM,</p>
            </div>
        </a>

        <footer class="post-card-meta">
            <ul class="author-list">
                <li class="author-list-item">
                    <a href="/author/r/" class="static-avatar">
                        <img class="author-profile-image" src="/content/images/size/w100/2019/08/pp.jpeg" alt="Raffaele T." loading="lazy" />
                    </a>
                </li>
            </ul>
            <div class="post-card-byline-content">
                <span><a href="/author/r/">Raffaele T.</a></span>
                <span class="post-card-byline-date"><time datetime="2022-01-13">Jan 13, 2022</time> <span class="bull">&bull;</span> 4 min read</span>
            </div>
        </footer>

    </div>

</article>
                    
<article class="post-card post ">

    <a class="post-card-image-link" href="/draft-automating-the-little-things-might-actually-be-a-bad-idea/">
        <img class="post-card-image"
            srcset="/content/images/size/w300/2022/01/shift6mq-knoll.jpeg 300w,
                    /content/images/size/w600/2022/01/shift6mq-knoll.jpeg 600w,
                    /content/images/size/w1000/2022/01/shift6mq-knoll.jpeg 1000w,
                    /content/images/size/w2000/2022/01/shift6mq-knoll.jpeg 2000w"
            sizes="(max-width: 1000px) 400px, 800px"
            src="/content/images/size/w600/2022/01/shift6mq-knoll.jpeg"
            alt="The SHIFT6mq in pieces"
            loading="lazy"
        />
    </a>

    <div class="post-card-content">

        <a class="post-card-content-link" href="/draft-automating-the-little-things-might-actually-be-a-bad-idea/">
            <header class="post-card-header">
                <h2 class="post-card-title">Automating the little things</h2>
            </header>
            <div class="post-card-excerpt">
                <p>As the mainline porting workflow becomes more streamlined, we found ourselves able to automate and simplify a lot of things that previously required a lot of manual work. A great example of this is the mdss-panel-driver-generator which is able to convert vendor devicetree panel control sequences into a driver which</p>
            </div>
        </a>

        <footer class="post-card-meta">
            <ul class="author-list">
                <li class="author-list-item">
                    <a href="/author/caleb/" class="static-avatar">
                        <img class="author-profile-image" src="/content/images/size/w100/2021/10/me.jpg" alt="Caleb Connolly" loading="lazy" />
                    </a>
                </li>
            </ul>
            <div class="post-card-byline-content">
                <span><a href="/author/caleb/">Caleb Connolly</a></span>
                <span class="post-card-byline-date"><time datetime="2022-01-06">Jan 6, 2022</time> <span class="bull">&bull;</span> 3 min read</span>
            </div>
        </footer>

    </div>

</article>

    </div>
</aside>


    </div>

    <footer class="site-footer outer">
        <div class="inner">
            <section class="copyright"><a href="https://tuxphones.com">TuxPhones - Linux phones, tablets and portable devices</a> &copy; 2022</section>
            <nav class="site-footer-nav">
                
            </nav>
            <div><a href="https://ghost.org/" target="_blank" rel="noopener">Powered by Ghost</a></div>
        </div>
    </footer>

</div>


<script
    src="https://code.jquery.com/jquery-3.5.1.min.js"
    integrity="sha256-9/aliU8dGd2tb6OSsuzixeV4y/faTqgFtohetphbbj0="
    crossorigin="anonymous">
</script>
<script src="/assets/built/casper.js?v=3c2405e8bf"></script>
<script>
$(document).ready(function () {
    // Mobile Menu Trigger
    $('.gh-burger').click(function () {
        $('body').toggleClass('gh-head-open');
    });
    // FitVids - Makes video embeds responsive
    $(".gh-content").fitVids();
});
</script>



</body>
</html>
